Back to overview
Degraded

Latency increased

Jun 26 at 09:30am CEST
Affected services
mkro1-es-mad

Resolved
Jun 27 at 09:17am CEST

Resolved

Updated
Jun 26 at 10:00am CEST

Path's Madrid PoP is currently down, currently it's running on a backup connection.

Created
Jun 26 at 09:30am CEST

We have found out that one of our routers is having a high latency.